The load balancer issue has been addressed. The website functionality has recovered.
Resolved
Identified
Load balancer issue identified, we are currently working on a fix.
Investigating
Load balancer update led to unexpected issues.